Volumio 2 on PINE64/ PINE A64-LTS / SOPINE Compute Module

Volumio portings supported by community members

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.

Volumio 2 on PINE64/ PINE A64-LTS / SOPINE Compute Module

Postby gkkpch » Tue Mar 27 2018 13:47

This thread offers people the opportunity to discuss PINE64/ PINE A64-LTS / SOPINE Compute Module board versions maintained by me.
These images will not be released on the download page.
Anyone willing to help maintaining the PINE64/ PINE A64-LTS / SOPINE Compute Module platform is very welcome.

New images will be built at regular times to follow up on finished Volumio development cycles.
They will also be built on request (if there is appropriate demand for it).

This opening post will hold links to generated PINE A64-LTS / SOPINE Compute Module image versions.

Current and previous links to downloads

Volumio for PINE A64-LTS / SOPINE Compute Module
volumio-2.383-2018-03-17-sopine64
- supports booting from eMMC and SD card
- supports a select number of simple I2S DACS. tested with the Pine64 DAC POT, a wired ES9023 DAC module and a pcm5121 DAC module.

Volumio for PINE A64
volumio-2.383-2018-03-17-pine64
- supports a select number of simple I2S DACS.
Tested with the Pine64 DAC POT, a wired ES9023 DAC module and a pcm5121 DAC module.
Most old PI/PI2+ DACs should work (provided they do not need I2C for control).
User avatar
gkkpch
Moderator
 
Posts: 1307
Joined: Mon Dec 29 2014 22:38
Location: Bodensee, Switzerland

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.


Volumio 2 on PINE64/ PINE A64-LTS / SOPINE Compute Module

Postby electricky » Thu May 24 2018 00:26

volumio-2.166-2017-05-11-pine64.img booting successful but I have a problem with last version for PINE A64:

[ 14.082739] sunxi-ehci 1c1a000.ehci0-controller: USB 0.0 started, EHCI 1.00
[ 14.090354] ehci_irq: highspeed device connect
[ 14.095591] hub 1-0:1.0: USB hub found
[ 14.099696] hub 1-0:1.0: 1 port detected
[ 14.104123] scene_lock_init name=ehci_standby
[ 14.108885] [ohci0-controller]: sunxi_usb_enable_ohci
[ 14.114417] [sunxi-ohci0]: probe, pdev->name: 1c1a000.ohci0-controller, sunxi_ohci: 0xffffffc000c0f868
[ 14.124639] sunxi-ohci 1c1a000.ohci0-controller: SW USB2.0 'Open' Host Controller (OHCI) Driver
[ 14.134170] sunxi-ohci 1c1a000.ohci0-controller: new USB bus registered, assigned bus number 3
[ 14.143615] sunxi-ohci 1c1a000.ohci0-controller: irq 105, io mem 0xffffffc0001a7f3c
[ 14.214851] hub 3-0:1.0: USB hub found
[ 14.218955] hub 3-0:1.0: 1 port detected
[ 14.223365] scene_lock_init name=ohci_standby
[ 14.357468] initramfs: /dev/mmcblk0p2 not detected,retrying mdev in 5 seconds
[ 14.417325] usb 1-1: new high-speed USB device number 2 using sunxi-ehci
[ 14.928255] initramfs: /dev/mmcblk0p2 not detected,retrying mdev in 5 seconds
[ 15.498803] initramfs: /dev/mmcblk0p2 not detected,retrying mdev in 5 seconds
[ 16.069820] initramfs: No partition with /dev/mmcblk0p2 has been found
Random avatar
electricky
Fresh off the boat
Fresh off the boat
 
Posts: 1
Joined: Thu May 24 2018 00:23


Volumio 2 on PINE64/ PINE A64-LTS / SOPINE Compute Module

Postby gkkpch » Tue May 29 2018 20:12

sure you picked the correct version?
User avatar
gkkpch
Moderator
 
Posts: 1307
Joined: Mon Dec 29 2014 22:38
Location: Bodensee, Switzerland


Volumio 2 on PINE64/ PINE A64-LTS / SOPINE Compute Module

Postby xiaoniuHIFI » Thu Jun 14 2018 09:16

Thank you for your great work.
Does this version support native dsd or dsd over pcm?
I have tested pcm up to 32bit 192khz, they are all good. But i2s has wrong BCLK when sample rates are higher than 96khz. Strangely, my dac just works fine with the wrong BCLK.

my dac board was built of es9028 and i use mcu to control it.
Random avatar
xiaoniuHIFI
Fresh off the boat
Fresh off the boat
 
Posts: 2
Joined: Thu Jun 14 2018 09:00


Volumio 2 on PINE64/ PINE A64-LTS / SOPINE Compute Module

Postby gkkpch » Thu Jun 14 2018 13:42

unfortunaly I can only use the driver as available in the current kernel, which is still based on Ayufan’s community work (kernel 3.10.105). So regarding BCLK there is nothing I can do.
The only “remedy” for the time being is resampling.
User avatar
gkkpch
Moderator
 
Posts: 1307
Joined: Mon Dec 29 2014 22:38
Location: Bodensee, Switzerland


Volumio 2 on PINE64/ PINE A64-LTS / SOPINE Compute Module

Postby xiaoniuHIFI » Fri Jun 15 2018 00:56

i will turn to use USB DAC, and hope it works fine.

thank you anyway.
Random avatar
xiaoniuHIFI
Fresh off the boat
Fresh off the boat
 
Posts: 2
Joined: Thu Jun 14 2018 09:00


Volumio 2 on PINE64/ PINE A64-LTS / SOPINE Compute Module

Postby joe_pine64 » Mon Jul 23 2018 18:20

Hello ,
Version 2.383-2018-03-17

If you have time please fix enable Volume Normalization headphones for the used have "hiss" , if i not to enable sound low

Thank !
User avatar
joe_pine64
Fresh off the boat
Fresh off the boat
 
Posts: 5
Joined: Wed Nov 29 2017 05:58


Volumio 2 on PINE64/ PINE A64-LTS / SOPINE Compute Module

Postby gkkpch » Mon Jul 23 2018 18:52

This seems to be an alsa/driver issue and there have not been any fixes made on this old kernel.
It is as good as it will get, there is nothing I can do about that, sorry.
I’m waiting for a mainline kernel, but that can take a while.

Best alternative for you is a USB DAC with a headphone jack, they will work out-of-the-box and have far better performance than the crappy onboard DAC.
User avatar
gkkpch
Moderator
 
Posts: 1307
Joined: Mon Dec 29 2014 22:38
Location: Bodensee, Switzerland


Volumio 2 on PINE64/ PINE A64-LTS / SOPINE Compute Module

Postby joe_pine64 » Mon Jul 23 2018 20:57

Sorry I remember wrong something please delete this post, thank
User avatar
joe_pine64
Fresh off the boat
Fresh off the boat
 
Posts: 5
Joined: Wed Nov 29 2017 05:58


Volumio 2 on PINE64/ PINE A64-LTS / SOPINE Compute Module

Postby kodachrome » Thu Aug 09 2018 16:19

Hi,
Can you post an updated Pine64 compatible build?
I tried this one and it works only if the Pine64 7" LCD module is disconnected, which sucks.

I posted in the Pine64 forum and was suggested to repost here.

Took me a long time to get around to this! However the Pine64 Touchscreen does not work with the latest Volumio (the only one I tested, volumio-2.383). Without the screen connected I logged in, enabled TouchScreen Plugin, shutdown, installed screen physically and.. wont boot. Cannot even access the device over IP and the red light eventually goes out.
Disconnect screen (just touchscreen cable even) and it will boot.

Tried the "Android 6.0.1 with LCD" build in PINE64 Installer and the screen & touch are working fine. There is some problem with Volumio + Touch & Screen. Any ideas?


thanks!
Random avatar
kodachrome
Fresh off the boat
Fresh off the boat
 
Posts: 3
Joined: Thu Aug 09 2018 16:17

Next

Return to Community portings

Who is online

Users browsing this forum: No registered users and 0 guests