Volumio does not reconnect WIFI/LAN after connection failure

Get help for Volumio here!

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.

Volumio does not reconnect WIFI/LAN after connection failure

Postby Scorpius » Wed Jan 11 2017 17:47

This has been in every Volumio version, now I have newest volumio version installed. Every time volumio losts connection to my local connection wlan/lan (it does not matter which) it cannot reconnect. This means I cannot connect it with terminal and reboot it -> hard reboot -> SD card corruption every few months -> PITA.

Is there any solution to this? My Kodi/OSMC have never done this and it always recovers from local connection down. One workaround could be cron script which senses internet down and reboots but this is merely a poor workaround for this problem...

Ideas? Help?
Random avatar
Scorpius
Fresh off the boat
Fresh off the boat
 
Posts: 6
Joined: Wed May 14 2014 07:07

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.


Volumio does not reconnect WIFI/LAN after connection failure

Postby balbuze » Wed Jan 11 2017 20:26

Hi,
this subject is being discussed.
Waiting a more elegant solution, I wrote a small plugin that check the state of connection by pinging 2 times a server every minute and restart it if no response.
It's not very clean, and the plugin appears as not active but it is.... It works for me, wifi eth and wifi.
It use a systemd.timer, not cron. So no new package is installed.
you can test here : https://github.com/balbuze/volumio-plugins/raw/master/plugins/system_controller/wifireconnect/wifireconnect.zip
But it's just a personal work.... ;)
User avatar
balbuze
Moderator
 
Posts: 1228
Joined: Thu May 08 2014 08:42
Location: Isère France


Volumio does not reconnect WIFI/LAN after connection failure

Postby patman » Thu Jan 12 2017 00:45

Having the same problem. Thank you for creating a plugin, unfortunately I'm getting an error installing it. The UI shows the following

Downloading plugin at http://127.0.0.1:3000/plugin-serve/wifireconnect.zip
END DOWNLOAD: http://127.0.0.1:3000/plugin-serve/wifireconnect.zip
Creating folder on disk
Unpacking plugin
Checking for duplicate plugin
Copying Plugin into location
Installing dependencies
The following error occurred when installing the plugin: Error

I'm a relative linux noob but I'm up to getting any log file if that would be helpful. I'm running version 2.041.

Thanks,
Pat.
Random avatar
patman
Fresh off the boat
Fresh off the boat
 
Posts: 9
Joined: Thu Jan 12 2017 00:35


Volumio does not reconnect WIFI/LAN after connection failure

Postby chsims1 » Thu Jan 12 2017 09:43

Have you by any chance changed the password from 'volumio' patman?
New to Volumio? Please read the Quick Start Guide to get your system up and running :).
User avatar
chsims1
Moderator
 
Posts: 916
Joined: Sat Aug 02 2014 10:44
Location: East Yorkshire, UK


Volumio does not reconnect WIFI/LAN after connection failure

Postby Scorpius » Thu Jan 12 2017 10:38

balbuze wrote:Hi,
this subject is being discussed.
Waiting a more elegant solution, I wrote a small plugin that check the state of connection by pinging 2 times a server every minute and restart it if no response.
It's not very clean, and the plugin appears as not active but it is.... It works for me, wifi eth and wifi.
It use a systemd.timer, not cron. So no new package is installed.
you can test here : https://github.com/balbuze/volumio-plugins/raw/master/plugins/system_controller/wifireconnect/wifireconnect.zip
But it's just a personal work.... ;)


Thanks for info balbuze! Good to know that its being discussed, hope it will be fixed in future releases. I installed your plugin thank you so much for that! 8-)
Random avatar
Scorpius
Fresh off the boat
Fresh off the boat
 
Posts: 6
Joined: Wed May 14 2014 07:07


Volumio does not reconnect WIFI/LAN after connection failure

Postby patman » Thu Jan 12 2017 17:40

chsims1 wrote:Have you by any chance changed the password from 'volumio' patman?


Thanks chsims1 - yes I did change it. I will set it back and try again when I get home tonight - too many warnings lately to not leave default passwords on devices so I try to be a little secure! And for the record just because I'm paranoid it does not mean they aren't out to get me :lol:

e: Yes changing the password back allowed the plugin to install, thanks!
Random avatar
patman
Fresh off the boat
Fresh off the boat
 
Posts: 9
Joined: Thu Jan 12 2017 00:35


Volumio does not reconnect WIFI/LAN after connection failure

Postby chsims1 » Fri Jan 13 2017 08:36

patman wrote: - too many warnings lately to not leave default passwords on devices so I try to be a little secure!


And rightly so ... hopefully a fix for this will be in the pipeline before too long (it has been mentioned elsewhere).
New to Volumio? Please read the Quick Start Guide to get your system up and running :).
User avatar
chsims1
Moderator
 
Posts: 916
Joined: Sat Aug 02 2014 10:44
Location: East Yorkshire, UK


Volumio does not reconnect WIFI/LAN after connection failure

Postby caunus » Thu Jan 19 2017 12:56

@balbuze great, thnaks for this little plugin. Hope this will help with my issue, that my little volumio installation sometime are not reachable anymore. Never the less as always some problems.
I installed the Version 0.0.6 looking into the system it seems to work.
Code: Select all
volumio@volumio:/etc/systemd/system$ systemctl | grep wifi
  wifireconnect.timer                                                                             loaded active waiting   Runs wifireconnect every 5min


But on the Plugin Management Screen the it's still inactive

Regards, Caunus
Random avatar
caunus
Sunday DIYer
Sunday DIYer
 
Posts: 16
Joined: Sun Dec 07 2014 18:38


Volumio does not reconnect WIFI/LAN after connection failure

Postby balbuze » Thu Jan 19 2017 13:04

Yes I know if appears as disable... But it works ! It's just a quick temporary workaround. Let me know if it helps in your case.
User avatar
balbuze
Moderator
 
Posts: 1228
Joined: Thu May 08 2014 08:42
Location: Isère France


Volumio does not reconnect WIFI/LAN after connection failure

Postby caunus » Thu Jan 19 2017 17:08

balbuze wrote:Yes I know if appears as disable... But it works ! It's just a quick temporary workaround. Let me know if it helps in your case.

I will let you know. Normally it takes a few days until the device is not accessible anymore. I'm not an expert but I was looking before also for some scripts, but they all needed some more packages to install. Never the less, at least I saw one which write into the system log, when restarting the network using the command logger. would be nice to have something similar, just in case to check if it's works.
Thanks again.
Random avatar
caunus
Sunday DIYer
Sunday DIYer
 
Posts: 16
Joined: Sun Dec 07 2014 18:38

Next

Return to Help

Who is online

Users browsing this forum: No registered users and 2 guests