how can remove "Chromium didn't shut down correctly"

Get help for Volumio here!

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.

how can remove "Chromium didn't shut down correctly"

Postby euijin1395 » Tue Jan 02 2018 03:17

Hi all,

this is my setup :
Raspberry P3 model B
16 GB Samsung Evo plus SD
waveshare 4 inch Capacitive Touch Screen 800 x 480 HDMI TFT LCD
volumio-2.344-2017-12-16-pi.img

When switch off by power, "Chromium didn't shut down correctly" massage display on the screen.
How can do not working it?
if i modify the volumiokiosk.sh file, "Chromium can not be run as root." massage box happen.
Random avatar
euijin1395
Fresh off the boat
Fresh off the boat
 
Posts: 1
Joined: Tue Jan 02 2018 03:11

Ads helps Volumio remain Free and Open Source. Please consider donating to help us continue to serve you.


how can remove "Chromium didn't shut down correctly"

Postby AndrewHeard » Tue Jan 02 2018 06:41

Happens on 25% of boots for me too. RPi3 is always correctly shutdown via volumio > settings > SHUTDOWN > Power Off. Doesn't seem to cause problems, just a noisy messagebox.
Random avatar
AndrewHeard
Serious Listener
Serious Listener
 
Posts: 71
Joined: Tue Dec 19 2017 05:15


how can remove "Chromium didn't shut down correctly"

Postby Randy » Sat Mar 03 2018 02:08

Greetings,
Posted this under another topic before I saw this message. Sorry for the double post, but it fits here better.

I was getting the "Chromium didn't shut down correctly" message at startup, too. It is coming from the "exit_type" and "exited_cleanly" fields within Chromium's Preferences file. It is located in "/data/volumiokiosk/Default".

Had seen post elsewhere that said to use sed in a startup script to change "exit_type": "Crashed" to"exit_type": "None" and "exited_cleanly": false to "exited_cleanly": true. This would not work for me for some reason I can't figure out.

However, simply deleting the Preferences file does the trick. If Chromium does not find the file it will create a new one with the default values.

Rather than create a new startup script, I modified "volumiokiosk.sh" in "/opt" by placing "rm /data/volumiokiosk/Default/Preferences" after the line "xset 0 0 120" and before "open-sission &". See below.

#!/bin/bash
xset +dpms
xset s blank
xset 0 0 120
rm /data/volumiokiosk/Default/Preferences
openbox-session &

while true; do
/usr/bin/chromium-browser \\
--disable-pinch \\
--kiosk \\
--no-first-run \\
--disable-3d-apis \\
--disable-breakpad \\
--disable-crash-reporter \\
--disable-infobars \\
--disable-session-crashed-bubble \\
--disable-translate \\Greetings,
I was getting the "Chromium didn't shut down correctly" message at startup, too. It is coming from the "exit_type" and "exited_cleanly" fields within Chromium's Preferences file. It is located in "/data/volumiokiosk/Default".

Had seen post elsewhere that said to use sed in a startup script to change "exit_type": "Crashed" to"exit_type": "None" and "exited_cleanly": false to "exited_cleanly": true. This would not work for me for some reason I can't figure out.

However, simply deleting the Preferences file does the trick. If Chromium does not find the file it will create a new one with the default values.

Rather than create a new startup script, I modified "volumiokiosk.sh" in "/opt" by placing "rm /data/volumiokiosk/Default/Preferences" after the line "xset 0 0 120" and before "open-sission &". See below.

#!/bin/bash
xset +dpms
xset s blank
xset 0 0 120
rm /data/volumiokiosk/Default/Preferences
openbox-session &

while true; do
/usr/bin/chromium-browser \\
--disable-pinch \\
--kiosk \\
--no-first-run \\
--disable-3d-apis \\
--disable-breakpad \\
--disable-crash-reporter \\
--disable-infobars \\
--disable-session-crashed-bubble \\
--disable-translate \\
--user-data-dir='/data/volumiokiosk' \
--no-sandbox \
http://localhost:3000
done

I was also having an issue with the album covers not changing while being stuck on one cover. This turned out to be an issue with Chromium not flushing the cache. Adding "rm /data/volumiokiosk/Default/Cache/*" in the same place corrected this issue.
--user-data-dir='/data/volumiokiosk' \
--no-sandbox \
http://localhost:3000
done

I was also having an issue with the album covers not changing while being stuck on one cover. This turned out to be an issue with Chromium not flushing the cache. Adding "rm /data/volumiokiosk/Default/Cache/*" in the same place corrected this issue.
Random avatar
Randy
Sunday DIYer
Sunday DIYer
 
Posts: 17
Joined: Fri Mar 02 2018 01:14
Location: Chesapeake, VA


how can remove "Chromium didn't shut down correctly"

Postby angelo.b » Fri Dec 21 2018 21:51

ciao.potete darmi il comando completo ?non so come accedere al file
grazie
Random avatar
angelo.b
Sunday DIYer
Sunday DIYer
 
Posts: 25
Joined: Fri Dec 15 2017 14:39


how can remove "Chromium didn't shut down correctly"

Postby angelo.b » Fri Dec 21 2018 22:19

sono riuscito con" sudo nano /opt/volumiokiosk.sh"
ma il messaggio "chromium non si e chiuso correttamente "rimane sempre.anche se lo spengo correttamente.
aiuto
Random avatar
angelo.b
Sunday DIYer
Sunday DIYer
 
Posts: 25
Joined: Fri Dec 15 2017 14:39


how can remove "Chromium didn't shut down correctly"

Postby gkkpch » Sat Dec 22 2018 12:07

Please use english as a discussion language.
If this is too difficult, don't give up.
You can always use the google translator to translate from italian.
That may not be perfect but works pretty well most of the time:


I managed with "sudo nano /opt/volumiokiosk.sh"
but the message "chromium has not been properly closed" remains always. even if I turn it off correctly.
Help


hi. can you give me the complete command? I do not know how to access the file
thank you
Volumio OS Developer

You like my work? Then what about buying me a beer :)
User avatar
gkkpch
Moderator
 
Posts: 1507
Joined: Mon Dec 29 2014 22:38
Location: Bodensee, Switzerland


how can remove "Chromium didn't shut down correctly"

Postby thierry sab » Sat Dec 22 2018 16:08

Hi,

For me also it's happen 80% on the boot, just before the start of the "touch display" : a little window appears: "Chromium didn't shut down correctly" "Restore ? " , I click on the button "restore" and I access to the touch display of VOLUMIO..

Is there a "workaround" ?
To remove the plug in "touch ui" and reinstall it?

- RPI 3B+
-official touch screen 7 " of Raspberry

Many thanks..
Random avatar
thierry sab
Fresh off the boat
Fresh off the boat
 
Posts: 9
Joined: Mon Dec 10 2018 14:09


how can remove "Chromium didn't shut down correctly"

Postby angelo.b » Sun Dec 30 2018 14:55

my friend knows that this error we must keep.io I followed the guide and I had to reinstall volumio.ho did the update but nothing.volumio subkey always displays chromium error. the only way and shut down safely. from interface or with buttons. but I risk keeping the raspberry in stanby and unloading the battery. I do not run it for domestic and perfect use.
Random avatar
angelo.b
Sunday DIYer
Sunday DIYer
 
Posts: 25
Joined: Fri Dec 15 2017 14:39


Return to Help

Who is online

Users browsing this forum: No registered users and 0 guests